Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
SiriusDog

Member
Registered:
Posts: 1
Reply with quote  #1 
Just received the new four gallon BP-4.  The pump runs but no fluid comes out the wand.  Suspecting wand may be plugged with something I removed it but still no fluid.  Depressed the yellow button on the pump as directed in the manual.  Still no luck.  The uptake tube inside the tank has air in it so I cleared it of air.  Still no luck.  Is there anything else I can do to get the pump to pump fluid?
Kurt Becker

Avatar / Picture

Dramm Staff
Registered:
Posts: 152
Reply with quote  #2 
Depressing the yellow button under the blue cover is the best option.  However, its function is to purge air from the system.  It needs to be done a number of times.  Additionally, depressing the button several times while pulling the trigger will also help.

If this does not work, call us at 800/258.0848 and talk to Phil in our service department to troubleshoot further.


__________________
Kurt Becker
Dramm Corporation
920/645.6417
dowlicd

Member
Registered:
Posts: 1
Reply with quote  #3 
Called and talked to Phil regarding this issue, and he walked me through it on the phone step by step.  And it worked!  If you take off the 4 screws connecting the yellow button you can access the filter inside.  Unless the manifold is worn out, there's usually just dirt or debris inside that area.  Only took me about 20-30 min to fix.  Thanks Phil!
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.