Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
SCOTTYB

Member
Registered:
Posts: 2
Reply with quote  #1 
Hi,

I recently purchased the 76cm Trigger Wand with the 400PL Water Breaker Head
and the 1000PL Water Breaker Head after researching and reading some very positive reviews and comments.

I am finding the flow from the 
400PL Water Breaker Head is very inconsistent in that the flow will not always 'shower', but more often than not the flow will become similar to that from a large bath tap.

When using the 
1000PL Water Breaker Head I get the same result all the time ie no 'shower' at all.

I've tried varying the water pressure from the tap, checked hoses for kinks, tried different angles of holding the 'wand' and different levels of pressure on the 'trigger'.  There do not seem to be missing 'o' rings, although I don't have a schematic to properly compare to.

What should I be checking for to correct the problem?  Is it possible that there is a fault, or a part missing from the unit?

Kind Regards,
Scott
Kurt Becker

Avatar / Picture

Dramm Staff
Registered:
Posts: 169
Reply with quote  #2 
This could be a result of the flow supplied to the wand.  Given the description in metric, I will assume you are in Europe.  Often, European hoses are smaller in diameter than in the US.  This will restrict the flow to the wand greatly, resulting in the condition you describe where the pattern collapses into a dribble.

The best choice in this situation is the 750PL.  If you contact me outside of the forum with your address, I will have one shipped to you at no charge.

You can reach me via email at kbecker@dramm.com.

__________________
Kurt Becker
Dramm Corporation
920/645.6417
SCOTTYB

Member
Registered:
Posts: 2
Reply with quote  #3 
Hi Kurt, 

Thanks for the reply, and generous offer.  

I've emailed as requested - would you mind confirming receipt?

Kind Regards,
Scott
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.